Facebook Google Plus Twitter LinkedIn YouTube RSS Menu Search Resource - BlogResource - WebinarResource - ReportResource - Eventicons_066 icons_067icons_068icons_069icons_070

MariaDB Server 5.5.x < 5.5.45 / 10.1.x < 10.1.7 DoS

Medium

Synopsis

The remote database server is affected by a Denial of Service (DoS) attack vector.

Description

MariaDB is a community-developed fork of the MySQL relational database. The version of MariaDB installed on the remote host is 5.5.x earlier than 5.5.45 or 10.1.x earlier than 10.1.7, and is therefore affected by a flaw that exists in 'select_lex->non_agg_fields' that is triggered when using 'ONLY_FULL_GROUP_BY' in a stored procedure or trigger that is repeatedly executed. This may allow an authenticated attacker to cause a crash.

Solution

Upgrade to version 10.1.7 or later. If version 10.1.x cannot be obtained, version 5.5.45 has also been patched for this issue.