Facebook Google Plus Twitter LinkedIn YouTube RSS Menu Search Resource - BlogResource - WebinarResource - ReportResource - Eventicons_066 icons_067icons_068icons_069icons_070

MariaDB Server 5.5.x < 5.5.47 / 10.0.x < 10.0.23 / 10.1.x < 10.1.10 Multiple Vulnerabilities



The remote database server is affected by multiple attack vectors.


MariaDB is a community-developed fork of the MySQL relational database. The version of MariaDB installed on the remote host is 5.5.x earlier than 5.5.47, or 10.0.x earlier than 10.0.23, or 10.1.x earlier than 10.1.10, and is therefore affected by multiple vulnerabilities :

- A flaw exists in 'mysql_upgrade' that is due to the program leaking plaintext password information to the process listing when spawning a shell process to execute mysqlcheck. This may allow a local attacker to gain access to password information. (OSVDB 131918, OSVDB 131919) - A flaw exists in 'ha_innodb.cc' that is triggered when handling lower case table names. This may allow an authenticated attacker to cause a crash. (OSVDB 131923) - A flaw exists related to certificate validation in the 'ssl_verify_server_cert()' function in 'sql-common/client.c'. The issue is due to the server hostname not being verified to match a domain name in the Subject's Common Name (CN) or SubjectAltName field of the X.509 certificate. By spoofing the TLS/SSL server via a certificate that appears valid, an attacker with the ability to intercept network traffic (e.g. MiTM, DNS cache poisoning) can disclose and optionally manipulate transmitted data. (OSVDB 133627)


Upgrade to version 10.1.10 or later. If version 10.1.x cannot be obtained, versions 10.0.23 and 5.5.47 have also been patched for these issues.