Facebook Google Plus Twitter LinkedIn YouTube RSS Menu Search Resource - BlogResource - WebinarResource - ReportResource - Eventicons_066 icons_067icons_068icons_069icons_070

MariaDB Server 5.5.x < 5.5.47 / 10.0.x < 10.0.23 / 10.1.x < 10.1.9 Multiple DoS

Medium

Synopsis

The remote database server is affected by multiple Denial of Service (DoS) attack vectors.

Description

MariaDB is a community-developed fork of the MySQL relational database. The version of MariaDB installed on the remote host is 5.5.x earlier than 5.5.47, or 10.0.x earlier than 10.0.23, or 10.1.x earlier than 10.1.9, and is therefore affected by multiple vulnerabilities :

- A flaw exists that is triggered when handling UPDATE queries with JOIN. This may potentially allow an authenticated attacker to cause the database to crash. (OSVDB 130859) - A flaw exists that is triggered during the handling of View or Dervied fields. This may allow an authenticated attacker to cause a memory overrun, which will crash the database. (OSVDB 131920)

Solution

Upgrade to version 10.1.9 or later. If version 10.1.x cannot be obtained, versions 10.0.23 and 5.5.47 have also been patched for these issues.