Facebook Google Plus Twitter LinkedIn YouTube RSS Menu Search Resource - BlogResource - WebinarResource - ReportResource - Eventicons_066 icons_067icons_068icons_069icons_070

MariaDB Server 5.5.x < 5.5.48 / 10.0.x < 10.0.24 / 10.1.x < 10.1.12 Multiple DoS

Medium

Synopsis

The remote database server is affected by multiple Denial of Service (DoS) attack vectors.

Description

MariaDB is a community-developed fork of the MySQL relational database. The version of MariaDB installed on the remote host is 5.5.x earlier than 5.5.48, or 10.0.x earlier than 10.0.24, or 10.1.x earlier than 10.1.12, and is therefore affected by multiple vulnerabilities :

- A flaw exists in the 'SELECT_LEX::update_used_tables()' function in 'sql_lex.cc' that is triggered when handling semijoin conditions on used table updates. This may allow an authenticated attacker to crash the database. (OSVDB 134561) - A flaw exists in the 'JOIN::choose_subquery_plan()' function in 'opt_subselect.cc' that is triggered when handling nested IN clauses that contain SQ. This may allow an authenticated attacker to crash the database. (OSVDB 134562) - A flaw exists in the 'select_create::prepare()' function in 'sql_insert.cc' that is triggered during the handling of stored procedures in new tables. This may allow an authenticated attacker to crash the database. (OSVDB 134563)

Solution

Upgrade to version 10.1.12 or later. If version 10.1.x cannot be obtained, versions 10.0.24 and 5.5.48 have also been patched for these issues.