Facebook Google Plus Twitter LinkedIn YouTube RSS Menu Search Resource - BlogResource - WebinarResource - ReportResource - Eventicons_066 icons_067icons_068icons_069icons_070

PHP 5.6.x < 5.6.19 / 7.0.x < 7.0.4 Multiple Vulnerabilities



The remote web server uses a version of PHP that is affected by multiple vulnerabilities.


Versions of PHP 5.6.x prior to 5.6.19, or 7.0.x prior to 7.0.4 are vulnerable to the following issues :

- A flaw exists in 'sapi/cli/php_cli_server.c' that is triggered as the built-in HTTP server does not properly restrict file requests. This may potentially allow a remote attacker to gain unauthorized access to arbitrary files. (OSVDB 135345) - A use-after-free error exists in the Zend Opcache. The issue is triggered when updating cached directory names that have been cached in the current working directory. This may potentially allow a remote attacker to dereference already freed memory and potentially execute arbitrary code. (OSVDB 135346) - A NULL pointer dereference flaw exists in the 'Zip::ExtractTo()' function in 'ext/zip/php_zip.c'. This may potentially allow a remote attacker to cause a crash. (OSVDB 135347)


Upgrade to PHP version 7.0.4 or later. If 7.x cannot be obtained, 5.6.19 is also patched for these vulnerabilities.