Facebook Google Plus Twitter LinkedIn YouTube RSS Menu Search Resource - BlogResource - WebinarResource - ReportResource - Eventicons_066 icons_067icons_068icons_069icons_070

Apache Subversion 1.7.x < 1.7.21 / 1.8.x < 1.8.14 Multiple Vulnerabilities

Medium

Synopsis

The remote host is running a version of Apache Subversion (SVN) that contains multiple vulnerabilities.

Description

The version of Apache Subversion installed on the remote host is 1.7.x prior to 1.7.21, or 1.8.x prior to 1.8.14 and is affected by the following vulnerabilities :

- A security bypass flaw affects the 'mod_authz_svn' module as it does not properly restrict anonymous access in some mixed anonymous/authenticated environments when using Subversion with Apache httpd 2.4. (CVE-2015-3184) - An information disclosure flaw affects 'authz'. Subversion servers, both httpd and svnserve, will reveal some paths that should be hidden by path-based authz controls. (CVE-2015-3187)

Solution

Upgrade to Subversion 1.7.21 / 1.8.14 or later.