Facebook Google Plus Twitter LinkedIn YouTube RSS Menu Search Resource - BlogResource - WebinarResource - ReportResource - Eventicons_066 icons_067icons_068icons_069icons_070

PostgreSQL 9.0 < 9.0.19 / 9.1 < 9.1.15 / 9.2 < 9.2.10 / 9.3 < 9.3.6 / 9.4 < 9.4.1 Multiple Vulnerabilities

High

Synopsis

The database running on the remote server is affected by multiple vulnerabilities.

Description

The version of PostgreSQL installed on the remote host is 9.0.x prior to 9.0.19, 9.1.x prior to 9.1.15, 9.2.x prior to 9.2.10, 9.3.x prior to 9.3.6, or 9.4.x prior to 9.4.1 and is affected by multiple vulnerabilities :

- A privilege escalation vulnerability exists due to the 'make check' command not properly invoking initdb to specify authentication requirements for a database cluster to be used for tests. (CVE-2014-0067)

- An information disclosure vulnerability exists due to improper handling of restricted column values in constraint-violation error messages. (CVE-2014-8161)

- Multiple vulnerabilities exist due to several buffer overflow errors related to the 'to_char' functions. (CVE-2015-0241)

- Multiple vulnerabilities exist due to several stack-based buffer overflow errors in various '*printf()' functions. The overflows are due to improper validation of user-supplied input when formatting a floating point number where the requested precision is greater than approximately 500. (CVE-2015-0242)

- Multiple vulnerabilities exist due to an overflow condition in multiple functions in the 'pgcrypto' extension. The overflows are due to improper validation of user-supplied input when tracking memory sizes. (CVE-2015-0243)

- A SQL injection vulnerability exists due to improper sanitization of user-supplied input when handling crafted binary data within a command parameter.(CVE-2015-0244)

Solution

Upgrade to PostgreSQL 9.0.19 / 9.1.15 / 9.2.10 / 9.3.6 / 9.4.1, or later.