Facebook Google Plus Twitter LinkedIn YouTube RSS Menu Search Resource - BlogResource - WebinarResource - ReportResource - Eventicons_066 icons_067icons_068icons_069icons_070

Squid < 3.1.1 HTTP Header Injection

Medium

Synopsis

The remote proxy server is affected by an HTTP injection vulnerability.

Description

Squid versions prior to 3.1.1 are affected by an HTML Injection vulnerability due to improper neutralization of CRLF sequences in HTTP headers. A remote attacker can exploit this vulnerability by conducting HTTP response splitting attacks via a specially crafted header in a response.

Solution

Either upgrade to Squid version 3.1.1 or later, or apply the vendor-supplied patch.