Facebook Google Plus Twitter LinkedIn YouTube RSS Menu Search Resource - BlogResource - WebinarResource - ReportResource - Eventicons_066 icons_067icons_068icons_069icons_070

Flash Player < 15.0.0.243 (inferred) Multiple Vulnerabilities (APSB14-27)

High

Synopsis

The remote host is running a browser plugin that is affected by multiple vulnerabilities.

Description

Versions of Adobe Flash player equal or prior to 15.0.0.242 are outdated and thus unpatched for the following vulnerabilities :

- A security bypass vulnerability that allows an attacker to bypass the same-origin policy (CVE-2014-0580). - Multiple memory corruption vulnerabilities that allow an attacker to execute arbitrary code (CVE-2014-0587, CVE-2014-9164). - A use-after-free vulnerability that can result in arbitrary code execution (CVE-2014-8443). - An unspecified information disclosure vulnerability (CVE-2014-9162). - A stack-based buffer overflow vulnerability that can be exploited to execute arbitrary code or elevate privileges (CVE-2014-9163).

Solution

Upgrade to 16.0.0.235 from the vendor's website. Flash Player for Google Chrome and Internet Explorer should contain the next version of the Flash engine in their monthly updates. Users of Extended Support Release are recommended to run Flash 13.0.0.259, while Linux users should update to version 11.2.202.425.