Facebook Google Plus Twitter LinkedIn YouTube RSS Menu Search Resource - BlogResource - WebinarResource - ReportResource - Eventicons_066 icons_067icons_068icons_069icons_070

phpMyAdmin 4.0.x < 4.0.10.7 / 4.1.x < 4.1.14.8 / 4.2.x < 4.2.13.1 DoS (PMASA-2014-17)

Medium

Synopsis

The remote web server contains a PHP application that is affected by a potential denial of service vulnerability.

Description

Versions of phpMyAdmin earlier than 4.0.10.7, 4.1.14.8, or 4.2.13.1 are unpatched for a denial of service vulnerability due to the way the application handles very long passwords. An attacker attempting to authenticate repeatedly using a large password string may be able to trigger this condition on the server.

Solution

Either upgrade to phpMyAdmin 4.0.10.7, 4.1.14.8, 4.2.13.1 or later, or apply the patches from the referenced links.