phpMyAdmin 4.0.x < 4.0.10.7 / 4.1.x < 4.1.14.8 / 4.2.x < 4.2.13.1 Multiple Vulnerabilities (PMASA-2014-17 - PMASA-2014-18)

medium Nessus Plugin ID 79797

Synopsis

The remote web server hosts a PHP application that is affected by multiple vulnerabilities.

Description

According to its self-reported version number, the phpMyAdmin application hosted on the remote web server is 4.0.x prior to 4.0.10.7, 4.1.x prior to 4.1.14.8, or 4.2.x prior to 4.2.13.1. It is, therefore, affected by the following vulnerabilities :

- A flaw exists in handling overly long passwords. It is possible that a remote attacker can cause a denial of service by using a long password. (CVE-2014-9218)

- A cross-site scripting flaw exists due to the improper validation of URLs when handling redirection. A remote attacker, by using a specially crafted request, could execute arbitrary script code within the trust relationship of the browser and server. Note that this applies only to versions 4.2.x prior to 4.2.13.1.
(CVE-2014-9219)

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade to phpMyAdmin 4.0.10.7 / 4.1.14.8 / 4.2.13.1 or later, or apply the patches referenced in the vendor advisory.

See Also

http://www.phpmyadmin.net/home_page/security/PMASA-2014-17.php

http://www.nessus.org/u?683380d0

http://www.nessus.org/u?dcfab292

http://www.nessus.org/u?8a847dfb

http://www.phpmyadmin.net/home_page/security/PMASA-2014-18.php

http://www.nessus.org/u?cb7a3b51

Plugin Details

Severity: Medium

ID: 79797

File Name: phpmyadmin_pmasa_2014_18.nasl

Version: 1.6

Type: remote

Family: CGI abuses

Published: 12/8/2014

Updated: 4/11/2022

Configuration: Enable paranoid mode

Risk Information

CVSS Score Source: CVE-2014-9219

VPR

Risk Factor: Medium

Score: 4.4

CVSS v2

Risk Factor: Medium

Base Score: 4.3

Temporal Score: 3.4

Vector: AV:N/AC:M/Au:N/C:N/I:P/A:N

Temporal Vector: E:POC/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:phpmyadmin:phpmyadmin

Required KB Items: www/PHP, installed_sw/phpMyAdmin, Settings/ParanoidReport

Exploit Available: true

Exploit Ease: No exploit is required

Patch Publication Date: 12/3/2014

Vulnerability Publication Date: 12/3/2014

Reference Information

CVE: CVE-2014-9218, CVE-2014-9219

BID: 71434, 71435

CWE: 20, 74, 79, 442, 629, 711, 712, 722, 725, 750, 751, 800, 801, 809, 811, 864, 900, 928, 931, 990