Facebook Google Plus Twitter LinkedIn YouTube RSS Menu Search Resource - BlogResource - WebinarResource - ReportResource - Eventicons_066 icons_067icons_068icons_069icons_070

Synology DiskStation Manager <= 4.3-3827 'value' Parameter SQL Injection Vulnerability

High

Synopsis

The remote host is a Synology DiskStation that is running an outdated version of the DiskStation Manager.

Description

The observed version of Synology DiskStation Manager is, or is older than, 4.3-3827, and as such is vulnerable to a SQL injection vulnerability due to insufficient user input sanitation of the 'value' parameter to the 'photo/include/blog/article.php' script prior to its use in a SQL query.

Solution

Upgrade to version 5.0, or higher, to address this vulnerability.