Facebook Google Plus Twitter LinkedIn YouTube RSS Menu Search Resource - BlogResource - WebinarResource - ReportResource - Eventicons_066 icons_067icons_068icons_069icons_070

Apache Tomcat 7.0.x < 7.0.77 / 8.0.x < 8.0.43 / 8.5.x < 8.5.13 / 9.0.0.x < 9.0.0.M19 Multiple Vulnerabilities

High

Synopsis

The remote web server is missing an Apache Tomcat patch update.

Description

The version of Apache Tomcat installed on the remote host is version 7.0.x prior to 7.0.77, 8.0.x prior to 8.0.43, 8.5.x prior to 8.5.13, and 9.0.0.x prior to 9.0.0.M19, and is affected by multiple vulerabilities :

- An unspecified flaw exists in the pipelined request handling that is triggered when send file processing was used. This may result in responses being sent for different requests and may allow a remote attacker to disclose potentially sensitive information. (CVE-2017-5647) - A flaw exists in the handling of HTTP/2 GOAWAY Frames that is triggered as streams associated with the connections are not properly closed. With specially crafted HTTP/2 requests, a remote attacker can exhaust available threads, resulting in a denial of service. (CVE-2017-5650) - A flaw exists in the refactoring of HTTP connectors related to the processing of send files. This may cause the processor to be added to the processor cache twice, allowing a remote attacker to gain access to sensitive information from other sessions which use the processor for requests. (CVE-2017-5651)

Solution

Update to Apache Tomcat version 9.0.0.M19 or later. If version 9.0.0.x cannot be obtained, 8.5.13, 8.0.43, and 7.0.77 have also been patched for these vulnerabilities.