Facebook Google Plus Twitter LinkedIn YouTube RSS Menu Search Resource - BlogResource - WebinarResource - ReportResource - Eventicons_066 icons_067icons_068icons_069icons_070

Apache Tomcat 7.0.x < 7.0.76 / 8.0.x < 8.0.42 / 8.5.x < 8.5.12 / 9.0.0.x < 9.0.0.M18 Information Disclosure

Low

Synopsis

The remote web server is missing an Apache Tomcat patch update.

Description

The version of Apache Tomcat installed on the remote host is version 7.0.x prior to 7.0.76, 8.0.x prior to 8.0.42, 8.5.x prior to 8.5.12, and 9.0.0.x prior to 9.0.0.M18, and is affected by a flaw in the handling of object references that is triggered when calling certain application listeners. With a specially crafted web application, a local attacker may gain access to information associated with another web application.

Solution

Update to Apache Tomcat version 9.0.0.M18 or later. If version 9.0.0.x cannot be obtained, 8.5.12, 8.0.42, and 7.0.76 have also been patched for this vulnerability.