Facebook Google Plus Twitter LinkedIn YouTube RSS Menu Search Resource - BlogResource - WebinarResource - ReportResource - Eventicons_066 icons_067icons_068icons_069icons_070

Asterisk Multiple Vulnerabilities (AST-2013-001 / AST-2013-002 / AST-2013-003)

High

Synopsis

The remote VoIP server is affected by multiple vulnerabilities.

Description

According to the version in its SIP banner, the version of Asterisk running on the remote host is potentially affected by the following vulnerabilities :

- A buffer overflow exists in the SIP SDP headers and h264 video handling. NOTE:Only Affects version less than 11.2.2 (CVE-2013-2685)

- A denial of server exists in the HTTP POST requests with very large 'Conten-Length' header values. (CVE-2013-2686)

- An information disclosure exists in the INVITE, SUBSCRIBE and REGISTER transactions and improper settings for the configureatio options. (CVE-2013-2264)

Solution

Upgrade to Asterisk 1.8.20.2 / 10.12.2 / 11.2.2, Certified Asterisk 1.8.15-cert2 or apply the patches listed in the Asterisk advisory