Facebook Google Plus Twitter LinkedIn YouTube RSS Menu Search Resource - BlogResource - WebinarResource - ReportResource - Eventicons_066 icons_067icons_068icons_069icons_070

IBM Solid Database < 4.5.182 / 6.0.1069 / 6.3.49 / 6.5.0.4 Denial of Service Vulnerability

High

Synopsis

The remote database server is vulnerable to a remote code execution attack.

Description

The remote host is running IBM solidDB.

Versions of solidDB earlier than 4.5.182, 6.0.x earlier than 6.0.1069, 6.3.x earlier than 6.3 Fix Pack 8, and 6.5.x earlier than 6.5.0.4 are potentially affected by a denial of service vulnerability due to a flaw in the way the application handles the rpc_test_svc_readwrite and rpc_test_svc_done commands. A remote unauthenticated attacker, exploiting this flaw, could crash the affected host.

Solution

Upgrade to IBM solidDB 4.5.182, 6.0.1069, 6.3 Fix Pack 8, 6.5 Fix Pack 4, or later.