Facebook Google Plus Twitter LinkedIn YouTube RSS Menu Search Resource - BlogResource - WebinarResource - ReportResource - Eventicons_066 icons_067icons_068icons_069icons_070

PostgreSQL < 9.0.3 / 8.4.7 / 8.3.14 / 8.2.20 Code Execution Vulnerability

Medium

Synopsis

The remote database server is affected by a buffer overflow vulnerability.

Description

Versions of PostgreSQL earlier than 9.0.3, 8.4.7, 8.3.14, or 8.2.20 are potentially affected by a buffer overflow vulnerability in the contrib module intarray's input function for the query_int type. An attacker, exploiting this flaw, could potentially execute arbitrary code on the remote host subject to the privileges of the user running the affected application.

Solution

Upgrade to PostgreSQL 9.0.3, 8.4.7, 8.3.14, 8.2.20, or later.