Facebook Google Plus Twitter LinkedIn YouTube RSS Menu Search Resource - BlogResource - WebinarResource - ReportResource - Eventicons_066 icons_067icons_068icons_069icons_070

PostgreSQL < 8.4.2 / 8.3.9 / 8.2.15 / 8.1.19 / 8.0.23 / 7.4.27 Multiple Vulnerabilities

Medium

Synopsis

The remote host is vulnerable to multiple attack vectors.

Description

The remote host is running a version of PostgreSQL that is earelir than 8.4.2, 8.3.9, 8.2.15, 8.1.19, 8.0.23, or 7.4.27. Such versions are potentially affected by multiple vulnerabilities :

- NULL Bytes in SSL Certificates can be used to falsify client or server authentication. (CVE-2009-4034)

- Privilege escalation via changing session state in an index function. (CVE-2009-4136) - An integer overflow in the 'ExecChooseHashTableSize()' function of the 'backend/executor/nodeHash.c' source file which could lead to a denial of service. (CVE-2010-0733)

Solution

Upgrade to PostgreSQL 7.4.27, 8.0.23, 8.1.19, 8.2.15, 8.3.9, 8.4.2, or later.