Facebook Google Plus Twitter LinkedIn YouTube RSS Menu Search Resource - BlogResource - WebinarResource - ReportResource - Eventicons_066 icons_067icons_068icons_069icons_070

PostgreSQL Error Message Conversion Remote DoS

Medium

Synopsis

The remote host is vulnerable to a Denial of Service (DoS) attack.

Description

This version of PostgreSQL is vulnerable to a denial of service when processing malformed SQL statements. To exploit this flaw, an attacker would need a valid account and the ability to execute custom queries. Successful exploitation would result in the attacker shutting down the database.

Solution

Upgrade to version 7.4.24, 8.0.20, 8.1.16, 8.2.12, 8.3.6 or higher.