Facebook Google Plus Twitter LinkedIn YouTube RSS Menu Search Resource - BlogResource - WebinarResource - ReportResource - Eventicons_066 icons_067icons_068icons_069icons_070

Apache Tomcat < 4.1.37/5.5.26/6.0.16 Multiple Vulnerabilities



The remote host is vulnerable to multiple attack vectors.


The remote host is running Apache Tomcat.

This version of Tomcat is reported to be vulnerable to several flaws. First, the application fails to sanitize user input to the 'RequestDispatcher' method. An attacker exploiting this flaw could request content outside the web root (typically through the use of '../' or similar sequences). If successful, the attacker could gain access to confidential data. Second, the application is vulnerable to a cross-site scripting (XSS) attack via the 'HttpServerResponse.sendError()' function. The user-supplied data is echoed back within the response headers and could lead to arbitrary code being executed within the browser of Tomcat clients.


Upgrade or patch according to vendor recommendations.