Facebook Google Plus Twitter LinkedIn YouTube RSS Menu Search Resource - BlogResource - WebinarResource - ReportResource - Eventicons_066 icons_067icons_068icons_069icons_070

Apache mod_python < 3.2.8 Remote Command Execution

High

Synopsis

The remote host is vulnerable to an flaw that allows attackers to execute arbitrary commands.

Description

The remote Apache server is running a version of mod_python that is equal to 3.2.7. It is reported that a flaw was introduced with version 3.2.7. Specifically, if 'FileSession' has been enabled, a remote attacker can send a specially formatted session cookie that will, upon being parsed, force mod_python into executing arbitrary code. The exact details of the flaw are unknown.

Solution

Upgrade to version 3.2.8, 3.3.1 or higher.