Facebook Google Plus Twitter LinkedIn YouTube RSS Menu Search Resource - BlogResource - WebinarResource - ReportResource - Eventicons_066 icons_067icons_068icons_069icons_070

Cherokee Web Server < 0.4.17.1 auth_pam Authentication Format String

Critical

Synopsis

The remote host is vulnerable to a remote 'format string' flaw.

Description

The remote host is running the Cherokee web server. This version is vulnerable to a remote format string overflow. An attacker exploiting this flaw would only need to be able to connect to the web server and issue an HTTP 'GET' request. Upon successful exploitation, the attacker would be able to execute commands within the context of the web server.

Solution

Upgrade to version 0.4.17.1 or higher.