Facebook Google Plus Twitter LinkedIn YouTube RSS Menu Search Resource - BlogResource - WebinarResource - ReportResource - Eventicons_066 icons_067icons_068icons_069icons_070

thttpd < 2.21 Error Page XSS

Medium

Synopsis

The remote host is vulnerable to a Cross-Site Scripting (XSS) attack.

Description

The remote host is running a vulnerable version of Acme thttpd. It is reported that this version of thttpd fails to check URLs for the presence of script commands when generating error pages. An attacker may craft links containing scripting code in order to execute code within the context of the website.

Solution

Upgrade to thttpd 2.21 or higher.