Facebook Google Plus Twitter LinkedIn YouTube RSS Menu Search Resource - BlogResource - WebinarResource - ReportResource - Eventicons_066 icons_067icons_068icons_069icons_070

PHP < 4.0.4 php.cgi Shell Access Overflow

High

Synopsis

The remote web server uses a version of PHP that is affected by a buffer overflow vulnerability.

Description

The PHP CGI program 'php.cgi' is vulnerable to a buffer overflow. A remote attacker can overflow the buffer and execute arbitrary code on the system under the UID of the user owning the httpd process, usually "nobody." An attacker could exploit this vulnerability to change to contents of a Web page or gain root or administrator access to the system.

Solution

Upgrade to version 4.0.4 or higher.