Plugins

As information about new vulnerabilities is discovered and released into the general public domain, Tenable Research designs programs to detect them. These programs are named plugins and are written in the Nessus Attack Scripting Language (NASL). The plugins contain vulnerability information, a simplified set of remediation actions and the algorithm to test for the presence of the security issue. Tenable Research has published 203581 plugins, covering 82167 CVE IDs and 30943 Bugtraq IDs.

Search

Newest

IDNameProductFamilySeverity
190873Fedora 38 : mbedtls (2024-c7f1c839ac)NessusFedora Local Security Checks
medium
190872Fedora 38 : kernel (2024-987089eca2)NessusFedora Local Security Checks
medium
190871Fedora 39 : kernel (2024-88847bc77a)NessusFedora Local Security Checks
medium
190870Fedora 38 : rust-asyncgit / rust-bat / rust-cargo-c / rust-eza / etc (2024-993d3a78dd)NessusFedora Local Security Checks
critical
190869RHEL 8 : Red Hat Virtualization (RHSA-2024:0934)NessusRed Hat Local Security Checks
high
190868GitLab 16.4 < 16.7.6 / 16.8 < 16.8.3 / 16.9 < 16.9.1 (CVE-2024-0861)NessusCGI abuses
medium
190867GitLab 15.1 < 16.7.6 / 16.8 < 16.8.3 / 16.9 < 16.9.1 (CVE-2024-0410)NessusCGI abuses
low
190866GitLab 11.3 < 16.7.6 / 16.8 < 16.8.3 / 16.9 < 16.9.1 (CVE-2023-6736)NessusCGI abuses
medium
190865GitLab 16.9 < 16.9.1 (CVE-2024-1451)NessusCGI abuses
high
190864GitLab 16.5 < 16.7.6 / 16.8 < 16.8.3 / 16.9 < 16.9.1 (CVE-2023-6477)NessusCGI abuses
medium

Updated

IDNameProductFamilySeverity
502003Siemens CP 1604 and CP 1616 Improper Access Control (CVE-2013-0659)Tenable OT SecurityTenable.ot
critical
502002Siemens CP1604 and CP1616 (CVE-2018-13808)Tenable OT SecurityTenable.ot
critical
502001Siemens SIMATIC CP products Improper Access Control (CVE-2023-37194)Tenable OT SecurityTenable.ot
medium
502000Siemens CP1604 and CP1616 (CVE-2018-13809)Tenable OT SecurityTenable.ot
medium
501999Siemens CP1604 and CP1616 (CVE-2018-13810)Tenable OT SecurityTenable.ot
medium
501998Siemens SIMATIC CP Products Uncontrolled Resource Consumption (CVE-2023-37195)Tenable OT SecurityTenable.ot
medium
190808Amazon Linux 2 : atril (ALASMATE-DESKTOP1.X-2024-006)NessusAmazon Linux Local Security Checks
high
190804Amazon Linux 2 : atril (ALASMATE-DESKTOP1.X-2024-007)NessusAmazon Linux Local Security Checks
high
190796Nutanix AOS : Multiple Vulnerabilities (NXSA-AOS-6.5.5.5)NessusMisc.
high
190777QEMU < 8.2.1 Buffer OverflowNessusWindows
high