WordPress 4.8.x < 4.8.34 Multiple Vulnerabilities

high Web App Scanning Plugin ID 115814

Synopsis

WordPress 4.8.x < 4.8.34 Multiple Vulnerabilities

Description

According to its self-reported version number, the detected WordPress application is affected by multiple vulnerabilities :

- A weakness in the upgrade process that could allow Remote Code Execution (RCE) during the upgrade window

- A stored Cross-Site Scripting (XSS) via specially crafted block markup

- A stored Cross-Site Scripting (XSS) via Privacy Data Removal Requests

- Multiple stored Cross-Site Scripting (XSS) issues in the Interactivity API

- A stored Denial of Service (DoS) issue in the Interactivity API

- A stored Cross-Site Scripting (XSS) in Customizer selective refresh

- A stored Cross-Site Scripting (XSS) in the Categories block

- A stored Cross-Site Scripting (XSS) via specially crafted User Logins

- An unauthenticated discovery of unpublished Customizer changesets

- A stored Cross-Site Scripting (XSS) in the Playlist and Image blocks

- A stored Cross-Site Scripting (XSS) in the Comments Pagination blocks

- A privilege escalation allowing access to notes without post edit permissions

- An outdated root certificate bundle trusting revoked eMudhra certificates

Note that the scanner has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Update to WordPress version 4.8.34 or latest.

See Also

https://wordpress.org/news/2026/10/wordpress-7-1-4/

Plugin Details

Severity: High

ID: 115814

Type: Version Based

Published: 11/6/2026

Updated: 11/6/2026

Scan Template: api, basic, full, pci, quick, scan

Risk Information

VPR

Risk Factor: Critical

Score: 9.2

Percentile: 99.78

CVSS v2

Risk Factor: High

Base Score: 7.6

Vector: CVSS2#AV:N/AC:H/Au:N/C:C/I:C/A:C

CVSS Score Source: CVE-2026-119977

CVSS v3

Risk Factor: High

Base Score: 8.1

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

CVSS Score Source: CVE-2026-119977

Vulnerability Information

CPE: cpe:2.3:a:wordpress:wordpress:*:*:*:*:*:*:*:*

Exploit Ease: No known exploits are available

Vulnerability Publication Date: 10/29/2026

CISA Known Exploited Vulnerability Due Dates: 11/6/2026

Reference Information

CVE: CVE-2026-119977

CWE: 200, 299, 367, 400, 79, 862, 94

OWASP: 2010-A1, 2010-A2, 2010-A6, 2010-A8, 2010-A9, 2013-A1, 2013-A3, 2013-A5, 2013-A6, 2013-A7, 2013-A9, 2017-A1, 2017-A3, 2017-A5, 2017-A6, 2017-A7, 2017-A9, 2021-A1, 2021-A3, 2021-A6, 2021-A7, 2025-A1, 2025-A5, 2025-A6, 2025-A7

WASC: Cross-Site Scripting, Denial of Service, Information Leakage, Insufficient Authorization, Insufficient Transport Layer Protection, OS Commanding

CAPEC: 116, 13, 147, 169, 197, 209, 22, 224, 242, 27, 285, 287, 29, 290, 291, 292, 293, 294, 295, 296, 297, 298, 299, 300, 301, 302, 303, 304, 305, 306, 307, 308, 309, 310, 312, 313, 317, 318, 319, 320, 321, 322, 323, 324, 325, 326, 327, 328, 329, 330, 35, 472, 492, 497, 508, 573, 574, 575, 576, 577, 588, 59, 591, 592, 60, 616, 63, 643, 646, 651, 77, 79, 85

DISA STIG: APSC-DV-000460, APSC-DV-001810, APSC-DV-002400, APSC-DV-002490, APSC-DV-002510, APSC-DV-002630

HIPAA: 164.306(a)(1), 164.306(a)(2), 164.312(a)(1), 164.312(a)(2)(i)

ISO: 27001-A.10.1.2, 27001-A.12.6.1, 27001-A.13.1.1, 27001-A.14.1.2, 27001-A.14.1.3, 27001-A.14.2.5, 27001-A.18.1.3, 27001-A.6.2.2, 27001-A.9.1.2, 27001-A.9.4.1, 27001-A.9.4.4, 27001-A.9.4.5

NIST: sp800_53-AC-3, sp800_53-CM-6b, sp800_53-SC-12, sp800_53-SC-5, sp800_53-SI-10, sp800_53-SI-15, sp800_53-SI-16

OWASP API: 2019-API7, 2019-API8, 2023-API8

OWASP ASVS: 4.0.2-14.2.1, 4.0.2-5.2.5, 4.0.2-5.3.3, 4.0.2-8.3.4, 4.0.2-9.2.1

PCI-DSS: 3.2-2.2, 3.2-6.2, 3.2-6.5, 3.2-6.5.1, 3.2-6.5.4, 3.2-6.5.7, 3.2-6.5.8