Next.js 9.5.0 < 14.2.24 Cache Poisoning

low Web App Scanning Plugin ID 115789

Synopsis

Next.js 9.5.0 < 14.2.24 Cache Poisoning

Description

The version of Next.js installed on the remote host is prior to 14.2.24 or 15.x prior to 15.1.6. It is, therefore, affected by a race condition vulnerability in the Pages Router which, under certain misconfigurations, can cause normal endpoints to serve pageProps data instead of standard HTML, leading to cache poisoning.

Note that the scanner has not attempted to exploit this issue but has instead relied only on application's self-reported version number.

Solution

Upgrade to Next.js version 14.2.24 or later.

See Also

https://github.com/vercel/next.js/security/advisories/GHSA-qpjv-v59x-3qc4

Plugin Details

Severity: Low

ID: 115789

Type: Version Based

Published: 11/6/2026

Updated: 11/6/2026

Scan Template: basic, full, pci, quick, scan

Risk Information

VPR

Risk Factor: Low

Score: 3.9

Percentile: 52.75

CVSS v2

Risk Factor: Low

Base Score: 2.6

Vector: CVSS2#AV:N/AC:H/Au:N/C:P/I:N/A:N

CVSS Score Source: CVE-2025-32421

CVSS v3

Risk Factor: Low

Base Score: 3.7

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N

CVSS Score Source: CVE-2025-32421

Vulnerability Information

CPE: cpe:2.3:a:vercel:next.js:*:*:*:*:*:*:*:*

Exploit Available: true

Exploit Ease: Exploits are available

Vulnerability Publication Date: 5/5/2025

Reference Information

CVE: CVE-2025-32421