Next.js 15.1.x < 15.1.8 Denial of Service

high Web App Scanning Plugin ID 115788

Synopsis

Next.js 15.1.x < 15.1.8 Denial of Service

Description

The version of Next.js installed on the remote host is 15.1.x prior to 15.1.8. It is, therefore, affected by a cache poisoning vulnerability leading to a denial of service condition.

Note that the scanner has not attempted to exploit this issue but has instead relied only on application's self-reported version number.

Solution

Upgrade to Next.js version 15.1.8 or later.

See Also

https://github.com/vercel/next.js/security/advisories/GHSA-67rr-84xm-4c7r

Plugin Details

Severity: High

ID: 115788

Type: Version Based

Published: 11/6/2026

Updated: 11/6/2026

Scan Template: basic, full, pci, quick, scan

Risk Information

VPR

Risk Factor: Low

Score: 3

Percentile: 23.73

CVSS v2

Risk Factor: High

Base Score: 7.8

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:C

CVSS Score Source: CVE-2025-49826

CVSS v3

Risk Factor: High

Base Score: 7.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

CVSS Score Source: CVE-2025-49826

Vulnerability Information

CPE: cpe:2.3:a:vercel:next.js:*:*:*:*:*:*:*:*

Exploit Ease: No known exploits are available

Vulnerability Publication Date: 7/2/2025

Reference Information

CVE: CVE-2025-49826