Next.js 13.0.0 < 14.2.30 Information Disclosure

low Web App Scanning Plugin ID 115786

Synopsis

Next.js 13.0.0 < 14.2.30 Information Disclosure

Description

The version of Next.js installed on the remote host is 13.0.0 prior to 14.2.30 or 15.x prior to 15.2.2. It is, therefore, affected by an information disclosure vulnerability in the development server due to a lack of origin verification, allowing a malicious website visited by the developer to access sensitive development data.

Note that the scanner has not attempted to exploit this issue but has instead relied only on application's self-reported version number.

Solution

Upgrade to Next.js version 14.2.30 or later.

See Also

https://github.com/vercel/next.js/security/advisories/GHSA-3h52-269p-cp9r

Plugin Details

Severity: Low

ID: 115786

Type: Version Based

Published: 11/6/2026

Updated: 11/6/2026

Scan Template: basic, full, pci, quick, scan

Risk Information

VPR

Risk Factor: Low

Score: 1.2

Percentile: 0.01

CVSS v2

Risk Factor: Medium

Base Score: 5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:N

CVSS Score Source: CVE-2025-48068

CVSS v3

Risk Factor: Medium

Base Score: 4.3

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:N/A:N

CVSS Score Source: CVE-2025-48068

CVSS v4

Risk Factor: Low

Base Score: 2.3

Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:L/VI:N/VA:N/SC:L/SI:N/SA:N

CVSS Score Source: CVE-2025-48068

Vulnerability Information

CPE: cpe:2.3:a:vercel:next.js:*:*:*:*:*:*:*:*

Exploit Ease: No known exploits are available

Vulnerability Publication Date: 5/27/2025

Reference Information

CVE: CVE-2025-48068