Next.js 14.x < 14.2.26 Information Disclosure

medium Web App Scanning Plugin ID 115784

Synopsis

Next.js 14.x < 14.2.26 Information Disclosure

Description

The version of Next.js installed on the remote host is 11.1.4 prior to 12.3.6, 13.0.x prior to 13.5.10, 14.x prior to 14.2.26 or 15.x prior to 15.2.4. It is, therefore, affected by an information disclosure vulnerability where the x-middleware-subrequest-id header may be leaked to external hosts.

Note that the scanner has not attempted to exploit this issue but has instead relied only on application's self-reported version number.

Solution

Upgrade to Next.js version 14.2.26 or later.

See Also

https://github.com/vercel/next.js/security/advisories/GHSA-223j-4rm8-mrmf

Plugin Details

Severity: Medium

ID: 115784

Type: Version Based

Published: 11/6/2026

Updated: 11/6/2026

Scan Template: basic, full, pci, quick, scan

Risk Information

VPR

Risk Factor: Low

Score: 3

Percentile: 23.86

CVSS v2

Risk Factor: Medium

Base Score: 5.4

Vector: CVSS2#AV:N/AC:H/Au:N/C:C/I:N/A:N

CVSS Score Source: CVE-2025-30218

CVSS v3

Risk Factor: Medium

Base Score: 5.9

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N

CVSS Score Source: CVE-2025-30218

CVSS v4

Risk Factor: Medium

Base Score: 6.3

Vector: CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N

CVSS Score Source: CVE-2025-30218

Vulnerability Information

CPE: cpe:2.3:a:vercel:next.js:*:*:*:*:*:*:*:*

Exploit Ease: No known exploits are available

Vulnerability Publication Date: 4/1/2025

Reference Information

CVE: CVE-2025-30218