Next.js 15.3.x < 15.3.6 Remote Code Execution

critical Web App Scanning Plugin ID 115775

Synopsis

Next.js 15.3.x < 15.3.6 Remote Code Execution

Description

The version of Next.js installed on the remote host is 15.0.x prior to 15.0.5, 15.1.x prior to 15.1.9, 15.2.x prior to 15.2.6, 15.3.x prior to 15.3.6, 15.4.x prior to 15.4.8, 15.5.x prior to 15.5.7 or 16.0.x prior to 16.0.7. It is, therefore, affected by an unauthenticated remote code execution vulnerability in React Server Components due to insecure deserialization of payloads sent to Server Function endpoints (React2Shell).

Note that the scanner has not attempted to exploit this issue but has instead relied only on application's self-reported version number.

Solution

Upgrade to Next.js version 15.3.6 or later.

See Also

https://github.com/vercel/next.js/security/advisories/GHSA-9qr9-h5gf-34mp

Plugin Details

Severity: Critical

ID: 115775

Type: Version Based

Published: 11/6/2026

Updated: 11/6/2026

Scan Template: basic, full, pci, quick, scan

Risk Information

VPR

Risk Factor: Critical

Score: 9.6

Percentile: 99.95

CVSS v2

Risk Factor: Critical

Base Score: 10

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

CVSS Score Source: CVE-2025-55182

CVSS v3

Risk Factor: Critical

Base Score: 10

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H

CVSS Score Source: CVE-2025-55182

Vulnerability Information

CPE: cpe:2.3:a:vercel:next.js:*:*:*:*:*:*:*:*

Exploit Available: true

Exploit Ease: No known exploits are available

Vulnerability Publication Date: 11/28/2025

CISA Known Exploited Vulnerability Due Dates: 12/12/2025

Reference Information

CVE: CVE-2025-55182