Next.js 16.0.x < 16.2.11 Multiple Vulnerabilities

high Web App Scanning Plugin ID 115757

Synopsis

Next.js 16.0.x < 16.2.11 Multiple Vulnerabilities

Description

The version of Next.js installed on the remote host is 12.0.0 prior to 15.5.21 or 16.0.0 prior to 16.2.11. It is, therefore, affected by multiple vulnerabilities:

- A Server-Side Request Forgery vulnerability in rewrites via an attacker-controlled destination hostname. (CVE-2026-64645)

- A Server-Side Request Forgery vulnerability in Server Actions on custom servers. This issue only affects versions 14.1.1 and later. (CVE-2026-64649)

- A Middleware / Proxy bypass in App Router applications using Turbopack and a single locale. This issue only affects versions 16.0.0 and later. (CVE-2026-64642)

- A denial of service vulnerability in App Router applications using Server Actions. This issue only affects versions 13.0.0 and later. (CVE-2026-64641)

- A denial of service vulnerability due to unbounded Server Action payloads in the Edge runtime. This issue only affects versions 13.0.0 and later. (CVE-2026-64646)

- A denial of service vulnerability in the Image Optimization API using SVGs. This issue only affects versions 15.5.0 and later. (CVE-2026-64644)

- A cache confusion of response bodies for requests with bodies. This issue only affects versions 13.0.0 and later. (CVE-2026-64648)

- A cache confusion of response bodies for requests with bodies containing invalid UTF-8 byte sequences. This issue only affects versions 13.0.0 and later. (CVE-2026-64647)

- An unauthenticated disclosure of internal Server Function endpoints. This issue only affects versions 13.0.0 and later. (CVE-2026-64643)

Note that the scanner has not attempted to exploit these issues but has instead relied only on application's self-reported version number.

Solution

Upgrade to Next.js version 16.2.11 or later.

See Also

https://github.com/vercel/next.js/security/advisories/GHSA-4633-3j49-mh5q

https://github.com/vercel/next.js/security/advisories/GHSA-4c39-4ccg-62r3

https://github.com/vercel/next.js/security/advisories/GHSA-68g3-v927-f742

https://github.com/vercel/next.js/security/advisories/GHSA-6gpp-xcg3-4w24

https://github.com/vercel/next.js/security/advisories/GHSA-89xv-2m56-2m9x

https://github.com/vercel/next.js/security/advisories/GHSA-955p-x3mx-jcvp

https://github.com/vercel/next.js/security/advisories/GHSA-m99w-x7hq-7vfj

https://github.com/vercel/next.js/security/advisories/GHSA-p9j2-gv94-2wf4

https://github.com/vercel/next.js/security/advisories/GHSA-q8wf-6r8g-63ch

Plugin Details

Severity: High

ID: 115757

Type: Version Based

Published: 11/6/2026

Updated: 11/6/2026

Scan Template: basic, full, pci, quick, scan

Risk Information

VPR

Risk Factor: Medium

Score: 4.3

Percentile: 53.42

CVSS v2

Risk Factor: High

Base Score: 8.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:P/A:N

CVSS Score Source: CVE-2026-64642

CVSS v3

Risk Factor: High

Base Score: 8.2

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:N

CVSS Score Source: CVE-2026-64642

CVSS v4

Risk Factor: High

Base Score: 8.3

Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:L/VA:N/SC:N/SI:N/SA:N

CVSS Score Source: CVE-2026-64642

Vulnerability Information

CPE: cpe:2.3:a:vercel:next.js:*:*:*:*:*:*:*:*

Exploit Ease: No known exploits are available

Vulnerability Publication Date: 7/21/2026

Reference Information

CVE: CVE-2026-64641, CVE-2026-64642, CVE-2026-64643, CVE-2026-64644, CVE-2026-64645, CVE-2026-64646, CVE-2026-64647, CVE-2026-64648, CVE-2026-64649

CWE: 116, 201, 285, 407, 524, 601, 770, 834, 918

OWASP: 2010-A10, 2010-A4, 2010-A6, 2013-A10, 2013-A4, 2013-A5, 2013-A9, 2017-A5, 2017-A6, 2017-A9, 2021-A1, 2021-A10, 2021-A3, 2021-A6, 2025-A1, 2025-A5, 2025-A6

WASC: Application Misconfiguration, Denial of Service, Improper Output Handling, Information Leakage, Insufficient Authorization, URL Redirector Abuse

CAPEC: 1, 104, 116, 125, 127, 13, 130, 147, 169, 17, 197, 22, 224, 229, 230, 231, 285, 287, 290, 291, 292, 293, 294, 295, 296, 297, 298, 299, 300, 301, 302, 303, 304, 305, 306, 307, 308, 309, 310, 312, 313, 317, 318, 319, 320, 321, 322, 323, 324, 325, 326, 327, 328, 329, 330, 39, 402, 45, 469, 472, 482, 486, 487, 488, 489, 490, 491, 493, 494, 495, 496, 497, 5, 508, 51, 528, 573, 574, 575, 576, 577, 59, 60, 616, 643, 646, 647, 651, 668, 73, 76, 77, 79, 81, 85, 87

DISA STIG: APSC-DV-000460, APSC-DV-000500, APSC-DV-002400, APSC-DV-002560, APSC-DV-002630

HIPAA: 164.306(a)(1), 164.306(a)(2), 164.312(a)(1), 164.312(a)(2)(i)

ISO: 27001-A.12.6.1, 27001-A.13.1.1, 27001-A.14.1.2, 27001-A.14.1.3, 27001-A.14.2.5, 27001-A.18.1.3, 27001-A.6.2.2, 27001-A.9.1.2, 27001-A.9.4.1, 27001-A.9.4.4, 27001-A.9.4.5

NIST: sp800_53-AC-3, sp800_53-CM-6b, sp800_53-SC-5, sp800_53-SI-10, sp800_53-SI-15

OWASP API: 2019-API7, 2019-API8, 2023-API7, 2023-API8

OWASP ASVS: 4.0.2-14.2.1, 4.0.2-4.1.3, 4.0.2-5.1.5, 4.0.2-5.2.1, 4.0.2-5.2.6, 4.0.2-8.3.4

PCI-DSS: 3.2-2.2, 3.2-6.2, 3.2-6.5, 3.2-6.5.8, 3.2-6.5.9