Next.js 16.0.x < 16.3.3 Multiple Vulnerabilities

critical Web App Scanning Plugin ID 115755

Synopsis

Next.js 16.0.x < 16.3.3 Multiple Vulnerabilities

Description

The version of Next.js installed on the remote host is 10.0.0 prior to 15.5.24 or 16.0.0 prior to 16.3.3. It is, therefore, affected by multiple vulnerabilities:

- An unauthenticated remote code execution vulnerability on Windows-hosted servers due to a path traversal. This issue only affects versions 13.4.0 and later. (CVE-2026-75604)

- An unauthenticated remote code execution vulnerability in the Image Optimization API when AVIF files are optimized, due to a vulnerability in the underlying libheif library used by sharp. (GHSA-2xp9-vwfh-vxw4)

Note that the scanner has not attempted to exploit these issues but has instead relied only on application's self-reported version number.

Solution

Upgrade to Next.js version 16.3.3 or later.

See Also

https://github.com/vercel/next.js/security/advisories/GHSA-2xp9-vwfh-vxw4

https://github.com/vercel/next.js/security/advisories/GHSA-p293-qw3h-jr36

Plugin Details

Severity: Critical

ID: 115755

Type: Version Based

Published: 11/6/2026

Updated: 11/6/2026

Scan Template: basic, full, pci, quick, scan

Risk Information

VPR

Risk Factor: High

Score: 7.8

Percentile: 99.33

CVSS v2

Risk Factor: High

Base Score: 7.6

Vector: CVSS2#AV:N/AC:H/Au:N/C:C/I:C/A:C

CVSS Score Source: CVE-2026-75604

CVSS v3

Risk Factor: Critical

Base Score: 9

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:H

CVSS Score Source: CVE-2026-75604

Vulnerability Information

CPE: cpe:2.3:a:vercel:next.js:*:*:*:*:*:*:*:*

Exploit Available: true

Exploit Ease: Exploits are available

Vulnerability Publication Date: 8/24/2026

Reference Information

CVE: CVE-2026-75604