Next.js 16.0.x < 16.3.8 Multiple Vulnerabilities

high Web App Scanning Plugin ID 115752

Synopsis

Next.js 16.0.x < 16.3.8 Multiple Vulnerabilities

Description

The version of Next.js installed on the remote host is 15.0.0 prior to 15.5.27 or 16.0.0 prior to 16.3.8. It is, therefore, affected by multiple vulnerabilities:

- A Server-Side Request Forgery vulnerability in the Image Optimization API, where an attacker-controlled, allow-listed remote URL can lead to requests to private IP addresses. This issue only affects versions 16.0.0 and later. (CVE-2026-94483)

- A cache poisoning vulnerability in self-hosted applications using the Pages Router with SSG or ISR pages, allowing a page's cache entry to be replaced with content from a different route. (CVE-2026-94543)

- A cache poisoning vulnerability in applications using a root-level catch-all page together with SSG or ISR routes, leading to cross-user content substitution and persistent denial of service. (CVE-2026-94484)

- An information disclosure vulnerability in App Router metadata image routes built with webpack, which ignore the 'dynamicParams' route segment option. (CVE-2026-94485)

- An information disclosure vulnerability where pending 'use cache' fills are shared between Draft Mode and regular requests, leaking unpublished content. This issue only affects versions 16.0.0 and later. (CVE-2026-94544)

- A cache leak across root param values in nested 'use cache' functions when Cache Components are enabled. This issue only affects versions 16.0.0 and later. (CVE-2026-103004)

- An information disclosure vulnerability in the development server's Model Context Protocol endpoint, which does not verify the request origin. This issue only affects versions 16.0.0 and later. (CVE-2026-94486)

Note that the scanner has not attempted to exploit these issues but has instead relied only on application's self-reported version number.

Solution

Upgrade to Next.js version 16.3.8 or later.

See Also

https://github.com/vercel/next.js/security/advisories/GHSA-39w2-rjm5-chcv

https://github.com/vercel/next.js/security/advisories/GHSA-3w37-wq28-93x7

https://github.com/vercel/next.js/security/advisories/GHSA-4jqv-mc3x-m676

https://github.com/vercel/next.js/security/advisories/GHSA-cjq9-62q9-8jv4

https://github.com/vercel/next.js/security/advisories/GHSA-f87g-xv8r-7p7x

https://github.com/vercel/next.js/security/advisories/GHSA-h694-7cp9-m8p3

https://github.com/vercel/next.js/security/advisories/GHSA-mcj8-r9mp-w47p

Plugin Details

Severity: High

ID: 115752

Type: Version Based

Published: 11/6/2026

Updated: 11/6/2026

Scan Template: basic, full, pci, quick, scan

Risk Information

VPR

Risk Factor: Low

Score: 3.5

Percentile: 51.42

CVSS v2

Risk Factor: Medium

Base Score: 6.4

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:N

CVSS Score Source: CVE-2026-94486

CVSS v3

Risk Factor: Medium

Base Score: 6.5

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:L/A:N

CVSS Score Source: CVE-2026-94483

CVSS v4

Risk Factor: High

Base Score: 8.3

Vector: CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:H/VI:L/VA:N/SC:N/SI:N/SA:N

CVSS Score Source: CVE-2026-94483

Vulnerability Information

CPE: cpe:2.3:a:vercel:next.js:*:*:*:*:*:*:*:*

Exploit Ease: No known exploits are available

Vulnerability Publication Date: 9/30/2026

Reference Information

CVE: CVE-2026-103004, CVE-2026-94483, CVE-2026-94484, CVE-2026-94485, CVE-2026-94486, CVE-2026-94543, CVE-2026-94544