ABB CP635 HMI Lack of encryption or authenticity checks against firmware binary files (CVE-2019-7229)

high Tenable OT Security Plugin ID 500945

Synopsis

The remote OT asset is affected by a vulnerability.

Description

The ABB CP635 HMI uses two different transmission methods to upgrade its firmware and its software components: Utilization of USB/SD Card to flash the device and Remote provisioning process via ABB Panel Builder 600 over FTP. Neither of these transmission methods implements any form of encryption or authenticity checks against the new firmware HMI software binary files.

This plugin only works with Tenable.ot.
Please visit https://www.tenable.com/products/tenable-ot for more information.

Solution

Refer to the vendor advisory.

See Also

http://seclists.org/fulldisclosure/2019/Jun/34

http://www.nessus.org/u?414ede7d

http://www.nessus.org/u?a7b4a770

http://www.nessus.org/u?ef4a0c16

http://www.nessus.org/u?c268e98d

Plugin Details

Severity: High

ID: 500945

Version: 1.2

Type: remote

Family: Tenable.ot

Published: 3/29/2023

Updated: 9/20/2023

Risk Information

VPR

Risk Factor: High

Score: 7.3

CVSS v2

Risk Factor: Medium

Base Score: 5.4

Temporal Score: 4.2

Vector: CVSS2#AV:A/AC:M/Au:N/C:P/I:P/A:P

CVSS Score Source: CVE-2019-7229

CVSS v3

Risk Factor: High

Base Score: 8.3

Temporal Score: 7.5

Vector: CVSS:3.0/AV:A/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:P/RL:O/RC:C

Vulnerability Information

CPE: cpe:/o:abb:cp620-web_firmware, cpe:/o:abb:cp620_firmware, cpe:/o:abb:cp630-web_firmware, cpe:/o:abb:cp630_firmware, cpe:/o:abb:cp635-b_firmware, cpe:/o:abb:cp635-web_firmware, cpe:/o:abb:cp635_firmware

Required KB Items: Tenable.ot/ABB

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 6/24/2019

Vulnerability Publication Date: 6/24/2019

Reference Information

CVE: CVE-2019-7229

CWE: 494