Wago I/O-Check Service Buffer Overflow (CVE-2021-34566)

critical Tenable OT Security Plugin ID 500835

Synopsis

The remote OT asset is affected by a vulnerability.

Description

In WAGO I/O-Check Service in multiple products an unauthenticated remote attacker can send a specially crafted packet containing OS commands to crash the iocheck process and write memory resulting in loss of integrity and DoS.

This plugin only works with Tenable.ot.
Please visit https://www.tenable.com/products/tenable-ot for more information.

Solution

Refer to the vendor advisory.

See Also

https://cert.vde.com/en/advisories/VDE-2020-036/

Plugin Details

Severity: Critical

ID: 500835

Version: 1.4

Type: remote

Family: Tenable.ot

Published: 2/14/2023

Updated: 4/9/2024

Supported Sensors: Tenable OT Security

Risk Information

VPR

Risk Factor: Medium

Score: 6.0

CVSS v2

Risk Factor: High

Base Score: 9.4

Temporal Score: 7

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:C/A:C

CVSS Score Source: CVE-2021-34566

CVSS v3

Risk Factor: Critical

Base Score: 9.1

Temporal Score: 7.9

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/o:wago:752-8303%2f8000-002_firmware, cpe:/o:wago:750-81xx_series_firmware, cpe:/o:wago:750-82xx_series_firmware

Required KB Items: Tenable.ot/Wago

Exploit Ease: No known exploits are available

Patch Publication Date: 11/9/2022

Vulnerability Publication Date: 11/9/2022

Reference Information

CVE: CVE-2021-34566

CWE: 120