Rockwell (CVE-2022-1797)

high Tenable.ot Plugin ID 500653

Synopsis

The remote OT asset is affected by a vulnerability.

Description

The remote OT product is vulnerable as specified in advisory ICSA-22-144-01.

- A malformed Class 3 common industrial protocol message with a cached connection can cause a denial-of- service condition in Rockwell Automation Logix Controllers, resulting in a major nonrecoverable fault. If the target device becomes unavailable, a user would have to clear the fault and redownload the user project file to bring the device back online. (CVE-2022-1797)

This plugin only works with Tenable.ot. Please visit https://www.tenable.com/products/tenable-ot for more information.

Solution

Refer to the vendor advisory.

See Also

https://www.cisa.gov/uscert/ics/advisories/icsa-22-144-01

http://www.nessus.org/u?7064b0b5

Plugin Details

Severity: High

ID: 500653

Version: 1.2

Type: remote

Family: Tenable.ot

Published: 6/11/2022

Updated: 6/16/2022

Risk Information

VPR

Risk Factor: Medium

Score: 4.4

CVSS v2

Risk Factor: High

Base Score: 7.8

Vector: AV:N/AC:L/Au:N/C:N/I:N/A:C

CVSS Score Source: CVE-2022-1797

CVSS v3

Risk Factor: High

Base Score: 8.6

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:N/A:H

Vulnerability Information

CPE: cpe:/o:rockwellautomation:compact_guardlogix_5370_firmware, cpe:/o:rockwellautomation:compact_guardlogix_5380_firmware, cpe:/o:rockwellautomation:compactlogix_5370_firmware, cpe:/o:rockwellautomation:compactlogix_5380_firmware, cpe:/o:rockwellautomation:compactlogix_5480_firmware, cpe:/o:rockwellautomation:controllogix_5570_firmware, cpe:/o:rockwellautomation:controllogix_5580_firmware, cpe:/o:rockwellautomation:guardlogix_5570_firmware, cpe:/o:rockwellautomation:guardlogix_5580_firmware

Required KB Items: Tenable.ot/Rockwell

Exploit Ease: No known exploits are available

Patch Publication Date: 6/2/2022

Vulnerability Publication Date: 6/2/2022

Reference Information

CVE: CVE-2022-1797

CWE: 400