Schneider (CVE-2020-25180)

medium Tenable.ot Plugin ID 500647

Synopsis

The remote OT asset is affected by a vulnerability.

Description

Rockwell Automation ISaGRAF Runtime Versions 4.x and 5.x includes the functionality of setting a password that is required to execute privileged commands. The password value passed to ISaGRAF Runtime is the result of encryption performed with a fixed key value using the tiny encryption algorithm (TEA) on an entered or saved password. A remote, unauthenticated attacker could pass their own encrypted password to the ISaGRAF 5 Runtime, which may result in information disclosure on the device.

This plugin only works with Tenable.ot. Please visit https://www.tenable.com/products/tenable-ot for more information.

Solution

Refer to the vendor advisory.

See Also

https://www.cisa.gov/uscert/ics/advisories/icsa-20-280-01

http://www.nessus.org/u?92e65ec9

http://www.nessus.org/u?4dce6d5b

http://www.nessus.org/u?659f30cf

Plugin Details

Severity: Medium

ID: 500647

Version: 1.1

Type: remote

Family: Tenable.ot

Published: 4/28/2022

Updated: 4/28/2022

Risk Information

VPR

Risk Factor: Medium

Score: 4.4

CVSS v2

Risk Factor: Medium

Base Score: 4.3

Vector: AV:N/AC:M/Au:N/C:P/I:N/A:N

CVSS Score Source: CVE-2020-25180

CVSS v3

Risk Factor: Medium

Base Score: 6.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N

Vulnerability Information

CPE: cpe:/o:schneider-electric:micom_c264_firmware

Required KB Items: Tenable.ot/Schneider

Exploit Ease: No known exploits are available

Patch Publication Date: 3/18/2022

Vulnerability Publication Date: 3/18/2022

Reference Information

CVE: CVE-2020-25180

CWE: 798