Rockwell Logix Controllers Denial of Service (CVE-2012-6442)

high Tenable OT Security Plugin ID 500028

Synopsis

The remote OT asset is affected by a vulnerability.

Description

Rockwell Automation EtherNet/IP products allow remote attackers to cause a denial of service (control and communication outage) via a CIP message that specifies a reset.

This plugin only works with Tenable.ot.
Please visit https://www.tenable.com/products/tenable-ot for more information.

Solution

As mentioned by Rockwell, this vulnerability affects all EtherNet/IP products that conform to the CIP and EtherNet/IP specifications. Therefore, no patch is available.

Refer to the vendor advisory for mitigations.

See Also

https://www.cisa.gov/news-events/ics-advisories/icsa-13-011-03

https://www.nessus.org/u?af210ad9

https://www.nessus.org/u?5c145e8f

Plugin Details

Severity: High

ID: 500028

Version: 1.8

Type: remote

Family: Tenable.ot

Published: 2/7/2022

Updated: 12/26/2023

Supported Sensors: Tenable OT Security

Risk Information

VPR

Risk Factor: Low

Score: 3.6

CVSS v2

Risk Factor: High

Base Score: 7.8

Temporal Score: 5.8

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:C

CVSS Score Source: CVE-2012-6442

CVSS v3

Risk Factor: High

Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/h:rockwellautomation:5069-aen2tr:-, cpe:/h:rockwellautomation:compactlogix_l32e_controller:-, cpe:/h:rockwellautomation:compactlogix_l35e_controller:-, cpe:/h:rockwellautomation:1756-en2t:-, cpe:/h:rockwellautomation:1756-en2f:-, cpe:/h:rockwellautomation:1756-en2txt:-, cpe:/h:rockwellautomation:1756-en2tr:-, cpe:/h:rockwellautomation:1756-en2trxt:-, cpe:/h:rockwellautomation:1756-en3tr:-, cpe:/h:rockwellautomation:1756-en4tr:-, cpe:/h:rockwellautomation:1756-en4trxt:-, cpe:/h:rockwellautomation:1756-enbt:-, cpe:/h:rockwellautomation:1756-eweb:-, cpe:/h:rockwellautomation:1768-enbt:-, cpe:/h:rockwellautomation:1768-eweb:-, cpe:/h:rockwellautomation:1794-aentr_flex_i%2fo_ethernet%2fip_adapter:-, cpe:/h:rockwellautomation:5069-aentr:-

Required KB Items: Tenable.ot/Rockwell

Exploit Ease: No known exploits are available

Patch Publication Date: 1/24/2013

Vulnerability Publication Date: 1/24/2013

Reference Information

CVE: CVE-2012-6442

CWE: 119