HAProxy 1.5.x < 1.5.12 DoS

High Nessus Network Monitor Plugin ID 9978

Synopsis

The remote host is running a version of HAProxy that is affected by a Denial of Service (DoS) attack vector.

Description

The installed version of HAProxy installed is version 1.5.x prior to 1.5.12, and is affected by an out-of-bounds read flaw in the 'http_replace_value()' function in 'proto_http.c' that may allow a remote attacker to cause a denial of service.

Solution

Upgrade to HAProxy version 1.5.12 or higher.

See Also

http://www.haproxy.org/download/1.5/src/CHANGELOG

Plugin Details

Severity: High

ID: 9978

File Name: 9978.prm

Family: Web Servers

Published: 2017/03/02

Modified: 2017/03/02

Risk Information

Risk Factor: High

CVSSv2

Base Score: 7.8

Temporal Score: 6.8

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:C

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

CVSSv3

Base Score: 7.5

Temporal Score: 7.2

Vector: CVSS3#AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Temporal Vector: CVSS3#E:X/RL:O/RC:C

Vulnerability Information

Patch Publication Date: 2015/05/02

Vulnerability Publication Date: 2015/03/16

Reference Information

OSVDB: 152325