MongoDB 3.0.x < 3.0.7 / 3.1.x < 3.1.9 Authentication Bypass

High Nessus Network Monitor Plugin ID 9972

Synopsis

The remote host is running a MongoDB database is vulnerable to a remote authentication bypass attack vector.

Description

Versions of MongoDB 3.0.x prior to 3.0.7, and 3.1.x prior to 3.1.9 are affected by an unspecified flaw in LDAP authentication that may allow a remote attacker to bypass authentication mechanisms. No further details have been provided by the developer.

Solution

Upgrade to MongoDB version 3.1.9 or later. If version 3.1.x cannot be obtained, version 3.0.7 is also patched for this vulnerability.

See Also

https://jira.mongodb.org/browse/SERVER-20691

Plugin Details

Severity: High

ID: 9972

Family: Database

Published: 2017/02/24

Updated: 2019/03/06

Dependencies: 9559

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 9.3

Temporal Score: 8.1

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

CVSS v3.0

Base Score: 8.1

Temporal Score: 7.1

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:X/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:mongodb:mongodb

Patch Publication Date: 2015/10/13

Vulnerability Publication Date: 2016/01/11

Reference Information

CVE: CVE-2015-7882