OpenSSL 1.1.0 < 1.1.0e DoS

High Nessus Network Monitor Plugin ID 9971


The remote web server is running an outdated instance of OpenSSL and is affected by a Denial of Service (DoS) attack vector.


According to its banner, the version of OpenSSL on the remote host is version 1.1.0 prior to 1.1.0e and is affected by a flaw that is triggered when handling renegotiation handshakes where the 'Encrypt-Then-Mac' extension is negotiated when it was not in the initial handshake, or vice versa. This may allow a remote attacker to cause OpenSSL to crash.


Upgrade OpenSSL to version 1.1.0e or higher

See Also

Plugin Details

Severity: High

ID: 9971

Family: Web Servers

Published: 2017/02/22

Modified: 2017/02/22

Dependencies: 5563

Risk Information

Risk Factor: High


Base Score: 7.8

Temporal Score: 6.8

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:C

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C


Base Score: 7.5

Temporal Score: 7.1


Temporal Vector: CVSS3#E:X/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:openssl:openssl

Patch Publication Date: 2017/02/16

Vulnerability Publication Date: 2017/02/16

Reference Information

CVE: CVE-2017-3733

BID: 96269