PostgreSQL 9.2.x < 9.2.20 / 9.3.x < 9.3.16 / 9.4.x < 9.4.11 / 9.5.x < 9.5.6 / 9.6.x < 9.6.2 Multiple Vulnerabilities

High Nessus Network Monitor Plugin ID 9969

Synopsis

The database running on the remote server is affected by multiple attack vectors.

Description

The version of PostgreSQL installed on the remote host is 9.2.x prior to 9.2.20, 9.3.x prior to 9.3.16, 9.4.x prior to 9.4.11, 9.5.x prior to 9.5.6 or 9.6.x prior to 9.6.2 and is affected by a the following vulnerabilities :

- An off-by-one overflow condition exists in the 'quote_literal_cstr()' function. The issue is triggered as certain input is not properly validated when encased entirely in single quotes or backslashes. This may allow a remote attacker to cause a buffer overflow, resulting in a denial of service or potentially allowing the execution of arbitrary code.
- A flaw exists that is triggered during the handling of multiple concurrent calls of 'pg_strat_backup()' and 'pg_stop_backup()'. This may allow a remote attacker to cause a denial of service.
- An off-by-one overflow condition exists that is triggered as certain input is not properly validated when handling a filename supplied to 'ecpg' that ends with a dot. This may allow a remote attacker to cause a limited buffer overflow, resulting in a denial of service or potentially allowing the execution of arbitrary code.

Solution

Upgrade to PostgreSQL 9.6.2 or later. If 9.6.x cannot be obtained, 9.5.6, 9.4.11, 9.3.16, and 9.2.20 have also been patched for these vulnerabilities.

See Also

https://www.postgresql.org/docs/current/static/release-9-2-20.html

https://www.postgresql.org/docs/current/static/release-9-3-16.html

https://www.postgresql.org/docs/current/static/release-9-4-11.html

https://www.postgresql.org/docs/current/static/release-9-5-6.html

https://www.postgresql.org/docs/current/static/release-9-6-2.html

Plugin Details

Severity: High

ID: 9969

Family: Database

Published: 2017/02/21

Updated: 2019/03/06

Dependencies: 8705

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 7.8

Temporal Score: 6.8

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:C

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

CVSS v3.0

Base Score: 7.5

Temporal Score: 7.2

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Temporal Vector: CVSS:3.0/E:X/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:postgresql:postgresql

Patch Publication Date: 2017/02/09

Vulnerability Publication Date: 2017/02/09