HAProxy 1.6.x < 1.6.4 Multiple Vulnerabilities

High Nessus Network Monitor Plugin ID 9965

Synopsis

The remote host is running a version of HAProxy that is affected by multiple attack vectors.

Description

The installed version of HAProxy installed version 1.6.x prior to 1.6.4, and is affected by multiple vulnerabilities :

- An Off-by-one flaw exists in the SSL component that is triggered during ALPN and NPN list allocation. No further details have been provided. (OSVDB 135912)
- A flaw in the http-reuse component exists that is triggered as private connections are shared across backends. No further details have been provided by the vendor. (OSVDB 135913)
- An Off-by-one issue exists in the 'url_param' parser in the http component. No further details have been provided by the vendor. (OSVDB 135914)

Solution

Upgrade to HAProxy version 1.6.4 or higher.

See Also

http://www.HAProxy.org/download/1.6/src/CHANGELOG

Plugin Details

Severity: High

ID: 9965

File Name: 9965.prm

Family: Web Servers

Published: 2017/02/15

Modified: 2017/02/15

Risk Information

Risk Factor: High

CVSSv2

Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

CVSSv3

Base Score: 7.3

Temporal Score: 7

Vector: CVSS3#AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS3#E:X/RL:O/RC:C

Vulnerability Information

Patch Publication Date: 2016/03/14

Vulnerability Publication Date: 2016/03/14

Reference Information

OSVDB: 135912, 135913, 135914