PostgreSQL 9.1.x < 9.1.24 / 9.2.x < 9.2.19 / 9.3.x < 9.3.15 / 9.4.x < 9.4.10 / 9.5.x < 9.5.5 Multiple Vulnerabilities

High Nessus Network Monitor Plugin ID 9963


The database running on the remote server is affected by multiple attack vectors.


The version of PostgreSQL installed on the remote host is 9.1.x prior to 9.1.24, 9.2.x prior to 9.2.19, 9.3.x prior to 9.3.15, or 9.4.x prior to 9.4.10, or 9.5.x prior to 9.5.5 and is affected by multiple vulnerabilities :

- A use-after-free error exists that is triggered when executing aggregate functions using 'DISTINCT'. This may allow a remote attacker to dereference already freed memory and cause a crash.
- A flaw exists due to the Interactive installer downloading software insecurely over an HTTP connection. This may allow a man-in-the-middle attacker to potentially execute arbitrary code.


Upgrade to PostgreSQL 9.5.5 or later. If 9.5.x cannot be obtained, 9.4.10, 9.3.15, 9.2.19, and 9.1.24 have also been patched for this vulnerability.

See Also

Plugin Details

Severity: High

ID: 9963

Family: Database

Published: 2017/02/14

Updated: 2019/03/06

Dependencies: 8705

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 7.8

Temporal Score: 6.8

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:C

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

CVSS v3.0

Base Score: 7.5

Temporal Score: 7.2

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Temporal Vector: CVSS:3.0/E:X/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:postgresql:postgresql

Patch Publication Date: 2016/10/26

Vulnerability Publication Date: 2016/10/26

Reference Information

CVE: CVE-2016-7048