OpenSSL 1.0.2 < 1.0.2k Multiple Vulnerabilities

high Nessus Network Monitor Plugin ID 9934
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote web server is running an outdated instance of OpenSSL and is affected by multiple attack vectors.

Description

According to its banner, the version of OpenSSL on the remote host is version 1.0.2 prior to 1.0.2k and is affected by multiple vulnerabilities :

- An out-of-bounds read flaw exists in 'crypto/evp/e_chacha20_poly1305.c' that is triggered during the handling of packets when using the CHACHA20/POLY1305 cipher. This may allow a remote attacker to crash a process linked against the library. (CVE-2017-3731)
- A carry propagating flaw exists in the Montgomery squaring procedure in 'crypto/bn/asm/x86_64-mont5.pl'. This may cause 'BN_mod_exp' to produce incorrect results, which may potentially allow an attacker to derive information regarding private keys. (CVE-2017-3732)

Solution

Upgrade OpenSSL to version 1.0.2k or higher

See Also

https://www.openssl.org/news/secadv/20170126.txt

Plugin Details

Severity: High

ID: 9934

Family: Web Servers

Published: 2/2/2017

Updated: 3/6/2019

Dependencies: 5563

Nessus ID: 96873

Risk Information

CVSS v2

Risk Factor: High

Base Score: 7.8

Temporal Score: 6.8

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:C

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

CVSS v3

Risk Factor: High

Base Score: 7.5

Temporal Score: 7.2

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Temporal Vector: CVSS:3.0/E:X/RL:O/RC:C

Vulnerability Information

CPE: cpe:2.3:a:openssl:openssl:*:*:*:*:*:*:*:*

Patch Publication Date: 1/26/2017

Vulnerability Publication Date: 1/26/2017

Reference Information

CVE: CVE-2017-3731, CVE-2017-3732

BID: 95814, 95813