Apache HTTP Server 2.4.x < 2.4.25 Multiple Vulnerabilities

Medium Nessus Network Monitor Plugin ID 9908


The remote web server is missing an Apache HTTP Server patch update.


The version of Apache HTTP Server 2.4.x installed on the remote host is prior to 2.4.25. It is, therefore, affected by multiple vulnerabilities :

- A flaw exists in the 'mod_http2' component that is triggered when handling the 'LimitRequestFields' directive and endless HTTP/2 CONTINUATION frames. This may allow a remote attacker to inject unlimited request headers, exhausting available memory resources. (CVE-2016-8740)
- A flaw exists that is triggered when handling whitespace patterns in User-Agent headers. This may allow a remote attacker to use a specially crafted User-Agent header to cause the program to incorrectly handle sequences of requests, potentially interpreting responses incorrectly and polluting the cache, or disclosing content from one request to a second downstream user-agent. (CVE-2016-8743)


Upgrade to Apache HTTP Server version 2.4.25 or later.

See Also


Plugin Details

Severity: Medium

ID: 9908

Family: Web Servers

Published: 2017/01/25

Updated: 2019/03/06

Dependencies: 8947

Nessus ID: 96451

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 5

Temporal Score: 4.3

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

CVSS v3.0

Base Score: 5.3

Temporal Score: 5.1

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L

Temporal Vector: CVSS:3.0/E:X/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:apache:http_server

Patch Publication Date: 2016/12/20

Vulnerability Publication Date: 2016/12/04

Reference Information

CVE: CVE-2016-8740, CVE-2016-8743

BID: 94650, 95077

IAVA: 2017-A-0010