Apache Subversion 1.8.x < 1.8.17 / 1.9.x < 1.9.5 DoS

Medium Nessus Network Monitor Plugin ID 9907


The remote host is running a version of Apache Subversion (SVN) that is affected by a Denial of Service (DoS) attack vector.


The version of Apache Subversion installed on the remote host is version 1.8.x prior to 1.8.17 or 1.9.x prior to 1.9.5. It is, therefore, affected by an XXE (Xml eXternal Entity) injection flaw in the 'mod_dontdothat' module in 'libsvn_ra_serf/xml.c' that is triggered during the parsing of XML data. The issue is due to an incorrectly configured XML parser accepting XML external entities from an untrusted source. By sending specially crafted XML data, a remote attacker can exhaust available resources.


Upgrade to Apache Subversion 1.9.5 or later. If 1.9.5 cannot be obtained, 1.8.17 is also patched for these vulnerabilities.

See Also


Plugin Details

Severity: Medium

ID: 9907

File Name: 9907.prm

Family: Web Servers

Published: 2017/01/25

Modified: 2017/01/25

Dependencies: 8971

Risk Information

Risk Factor: Medium


Base Score: 5

Temporal Score: 4.3

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C


Base Score: 5.3

Temporal Score: 5.1


Temporal Vector: CVSS3#E:X/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:apache:subversion

Patch Publication Date: 2016/11/29

Vulnerability Publication Date: 2016/11/29

Reference Information

CVE: CVE-2016-8734

BID: 94588

OSVDB: 147947