ISC BIND 9.x < 9.9.8-P2 / 9.9.9-S3 / 9.10.3-P2 DoS

High Nessus Network Monitor Plugin ID 9868

Synopsis

The remote DNS server may be affected by a Denial of Service (DoS) attack vector.

Description

Versions of ISC BIND 9.x prior to 9.9.8-P2, 9.9.9-S3 and 9.10.3-P2 are unpatched for a flaw in 'resolver.c' that is triggered when handling socket errors. This may allow a remote attacker to potentially trigger an INSIST failure and cause a server to exit.

Solution

Upgrade ISC BIND to version 9.10.3-P2 or later. If version 9.10.x cannot be obtained, versions 9.9.9-S3 and 9.9.8-P2 are also patched for this vulnerability.

See Also

https://kb.isc.org/article/AA-01319/74/CVE-2015-8461%3A-A-race-condition-when-handling-socket-errors-can-lead-to-an-assertion-failure-in-resolver.c.html

https://kb.isc.org/article/AA-01398

Plugin Details

Severity: High

ID: 9868

Family: DNS Servers

Published: 2017/01/19

Updated: 2019/03/06

Dependencies: 1003

Nessus ID: 87503

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 7.1

Temporal Score: 6.2

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:N/A:C

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

CVSS v3.0

Base Score: 5.9

Temporal Score: 5.7

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H

Temporal Vector: CVSS:3.0/E:X/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:isc:bind

Patch Publication Date: 2015/12/15

Vulnerability Publication Date: 2015/12/15

Reference Information

CVE: CVE-2015-8461

BID: 79347