PHP 5.6.x < 5.6.29 DoS

Medium Nessus Network Monitor Plugin ID 9841


The remote web server uses a version of PHP that is affected by a Denial of Service (DoS) attack vector.


Versions of PHP 5.6.x prior to 5.6.29 are vulnerable to a flaw in the 'openssl_pbkdf2()' function in 'ext/openssl/openssl.c' that is triggered when handling overly large key length parameters. This may allow a remote attacker to crash a program using the language.


Upgrade to PHP version 5.6.29 or later.

See Also

Plugin Details

Severity: Medium

ID: 9841

File Name: 9841.prm

Family: Web Servers

Published: 2017/01/02

Modified: 2017/02/09

Dependencies: 8682

Risk Information

Risk Factor: Medium


Base Score: 5.4

Temporal Score: 4.7

Vector: CVSS2#AV:N/AC:H/Au:N/C:N/I:N/A:C

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C


Base Score: 5.8

Temporal Score: 5.5


Temporal Vector: CVSS3#E:X/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:php:php

Patch Publication Date: 2016/12/08

Vulnerability Publication Date: 2016/12/12